Forum

Intelligent Service Management: Deprecation of TLS 1.0 , TLS 1.1 and Browser Compatibility

  • 1.  Intelligent Service Management: Deprecation of TLS 1.0 , TLS 1.1 and Browser Compatibility

    Posted 04-23-2020 09:43

    Transport Layer Security (TLS) 1.0 will be deprecated on 27th April 2020 and TLS 1.1 will be supported until 30th June 2020. 


    What does this Mean?

    Serviceaide has announced that TLS 1.0 and 1.1 are out-of-date protocols that do not support modern cryptographic algorithms, and they contain security vulnerabilities that may be exploited by attackers. Support for TLS 1.0 is being deprecated from 27th April and 1.1 will be supported until 30th June 2020 and TLS 1.2 protocol will be supported. Google, Microsoft, Apple, and Mozilla have also announced that their browsers will no longer support TLS 1.0 and TLS 1.1 as of March 2020. 


    How does this impact me?

    At Serviceaide, we are planning to deprecate TLS 1.0 and TLS 1.1 support and upgrade to TLS 1.2. Below browsers will not work with ISM application after the deprecation:

    • Firefox 27
    • Chrome 30
    • IE 11 on Windows 7
    • Edge
    • Opera 17
    • Safari 9


    What do I do?

    Upgrade your browser to the latest versions to continue using ISM application. Below is the information on compatible browsers with the application:

    https://serviceaide.atlassian.net/wiki/spaces/CloudSMGoldfish/pages/2965397/Compatibility+Matrix

     Please contact Serviceaide support team for any other details and assistance.



    ------------------------------
    Sneha Tripathi
    Serviceaide
    ------------------------------